Enlace de tres RouterOS utilizando una red mayada con interfaces Ethernet (HWMP+)

Leinier Cruz Salfran
HWMP+, IPv4, IPv6, Maya, RouterOS, Tutoriales
23-jul-2020

Tabla de contenidos

Introducción

Este tutorial trata de como enlazar tres RouterOS a nivel capa 2 utilizando HWMP+, el cual es un protocolo, propietario de Mikrotik, de enrutamiento de nivel capa 2 para redes mayadas inalámbricas. Éste protocolo puede ser usado en lugar del Protocolo de Árbol de Expansión (Rápido), o por sus siglas en ingles (R)STP, en configuraciones de redes mayadas, y así asegurar un enrutamiento óptimo libre de bucles. Algo muy notorio en este protocolo es que puede estar compuesta tanto por interfaces inalámbricas como ethernets, el cual sera el punto de exposición en este tutorial.

Las redes mayadas que utilizan HWMP+, son parecidas a las tradicionales redes puente que utilizan (R)STP, con la diferencia de que ésta primera es inteligente y capaz de hacer llegar el paquete IP o datagrama IP utilizando la ruta de menor longitud, también, pueden sustituir a las tradicionales redes puente cuando todas las puertas de enlace principales de la red son equipos basados en RouterOS, o sea, cuando no se necesita interoperatibilidad con equipos de otros fabricantes que no soportan el protocolo HWMP+, por ejemplo, Cisco, Juniper, TP-Link, Ubiquiti, entre otros.

Casos de uso

Uno de los casos de uso más comunes puede ser la sustitución de las tradicionales redes puente por las redes mayadas basadas en HWMP+ cuando todos los puntos de acceso principales a la red mayada son equipos basados en RouterOS. Otro puede ser la creación de una red privada entre equipos basados en RouterOS destinada al acceso exclusivo a dicho equipos con fines de administración, separando así esta red de la red común por donde se transmiten todos los demás flujos.

Diagrama de red

Para la exposición de este tutorial se utilizará un laboratorio compuesto por 3 dispositivos RouterOS conectados en forma de bus como se muestra en el siguiente diagrama:

RouterOS #1

/interface mesh
add name=mesh1
/interface mesh port
add mesh=mesh1 interface=ether1
/ip address
add interface=mesh1 address=192.168.5.1/24
/ipv6 address
add interface=mesh1 address=fd05::1/64 advertise=no

RouterOS #2

/interface mesh
add name=mesh1
/interface mesh port
add mesh=mesh1 interface=ether1
add mesh=mesh1 interface=ether2
/ip address
add interface=mesh1 address=192.168.5.2/24
/ipv6 address
add interface=mesh1 address=fd05::2/64 advertise=no

RouterOS #3

/interface mesh
add name=mesh1
/interface mesh port
add mesh=mesh1 interface=ether1
/ip address
add interface=mesh1 address=192.168.5.3/24
/ipv6 address
add interface=mesh1 address=fd05::3/64 advertise=no

Comprobaciones

RouterOS #1

[admin@RouterOS1] > ping address=192.168.5.2 count=3       
  SEQ HOST                                     SIZE TTL TIME  STATUS                                                         
    0 192.168.5.2                                56  64 2ms  
    1 192.168.5.2                                56  64 1ms  
    2 192.168.5.2                                56  64 0ms  
    sent=3 received=3 packet-loss=0% min-rtt=0ms avg-rtt=1ms max-rtt=2ms

[admin@RouterOS1] > ping address=fd05::3 count=3 
  SEQ HOST                                     SIZE TTL TIME  STATUS                                                         
    0 fd05::3                                    56  64 5ms   echo reply
    1 fd05::3                                    56  64 3ms   echo reply
    2 fd05::3                                    56  64 3ms   echo reply

    sent=3 received=3 packet-loss=0% min-rtt=3ms avg-rtt=3ms max-rtt=5ms 

Vale realizar la siguiente aclaración: el campo TTL (Time To Live) es el indicador que la prueba ICMP está yendo directo desde RouterOS #1 hasta RouterOS #3 a través de RouterOS #2 (RouterOS #1 no está directamente conectado a RouterOS #3), pero, el salto que ejecuta es interno en la red mayada.